Article ID: 5256, created on Mar 12, 2009, last review on Apr 27, 2014

  • Applies to:
  • Plesk for Linux/Unix

Síntomas

Cuando los usuarios de correo intentan recibir emails a través de POP3/IMAP o enviar emails a través de SMTP una vez realizada la actualización a Parallels Plesk Panel 8.4, obtienen el error "Error de inicio de sesión". Este problema surje cuando la opción "Se permite el uso de nombres de cuenta de correo POP3/IMAP cortos (webmaster) y completos (webmaster@domain.com)" está activada en la página Servidor->Correo en el CP de Parallels Plesk Panel.

Resolución

En primer lugar, realice la actualización a Parallels Plesk Panel 8.4.0.1.

Si aún así sigue apareciendo este problema, ejecute el script adjunto a este artículo para solucionarlo.

Si realizando esta acción tampoco consigue solucionar la incidencia y obtiene el error "dicho usuario no existe" en /usr/local/psa/var/log/maillog, por ejemplo durante conexiones IMAP, compruebe que ha actualizado todos los paquetes de Parallels Plesk Panel a la build de Parallels Plesk Panel 8.4 (build84080*). Como Parallels Plesk Panel 8.4 usa un nuevo mecanismo de autorización de correo optimizado, puede que esto no funcione con los paquetes anteriores. En SOs basados en RPM, puede comprobarlo ejecutando el comando:
# rpm -qa | grep psa | grep -v 840

En el caso de usuarios de Ubuntu 7.10 i386: la utilidad mail_auth_dump no funciona correctamente con el paquete libdb4.4 = 4.4.20-8.1ubuntu3.1 del repositorio de actualizaciones gutsy. Como resultado, no se crea/actualiza el archivo de datos mail-auth principal /var/lib/plesk/mail/auth/passwd.db y no se pueden autorizar a los usuarios. Para resolver esta incidencia:

- compruebe cuál es la versión de libdb4.4 instalada:

# apt-cache policy libdb4.4
libdb4.4:
Installed: 4.4.20-8.1ubuntu3.1 <<<<<<<<
Candidate: 4.4.20-8.1ubuntu3.1

- Si tiene instalada la versión 4.4.20-8.1ubuntu3.1 -> cambie el paquetelibdb4.4 a la versión 4.4.20-8.1ubuntu3 desde el repositorio gutsy/principal:

# apt-get install libdb4.4=4.4.20-8.1ubuntu3

- Vuelva a generar el archivo de datos mail-auth /var/lib/plesk/mail/auth/passwd.db:
# /usr/local/psa/admin/sbin/mail_auth_dump

- compruebe que los datos de mail-auth están actualizados:
# /usr/local/psa/admin/sbin/mail_auth_view

Attachments

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF