Article ID: 549, created on Jan 26, 2009, last review on Sep 30, 2014

  • Applies to:
  • Plesk for Windows

Síntomas

1) Ninguno de los usuarios puede acceder a "domain.tld" mediante FTP. Se obtiene el siguiente mensaje de error:

    Cannot log in, home directory inaccessible

2) No se pueden cargar archivos mediante FTP:

An error occurred copying a file the FTP Server. Make sure you have permission to put files on the server.
    Details:
    200 Type set to I.
    227 Entering Passive Mode(1,2,3,4,5,28).
    550 test.html: Access is denied 

Causa

Este problema puede deberse a distintas causas. Este error aparece si:

  1. El nombre del host contiene más de 15 símbolos.

  2. El dominio resuelve a una IP diferente a la que se ha configurado en Parallels Plesk.

  3. El usuario no dispone de permiso de lectura para el directorio principal. IIS > ip_address > localuser > domain.com > Reglas de autorización de FTP.

  4. La configuración FTP del servidor está dañada.

  5. La ruta FTP_ROOT_D no se ha establecido correctamente en HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config.

  6. En IIS se ha especificado una ruta incorrecta. Para comprobar la ruta, vaya a Administrador de IIS > Sitios > Haga clic con el botón secundario del ratón en <server_ip_address> > Administrar sitio FTP > Configuración avanzada > Ruta física. La ruta no debería incluir ningún espacio.

    La ruta correcta es la siguiente: C:\inetpub\vhosts\Servers\8

    alttext

  7. El archivo de vinculación del usuario FTP C:\inetpub\vhosts\Servers\8\localuser\system_user\domain.tld\ no dispone de permisos de usuario FTP.

  8. En el siguiente artículo de Microsoft se describen otras causas posibles de esta incidencia: "Mensaje de error de IIS: "El usuario 530 no puede iniciar sesión. Error de inicio de sesión."

Resolución

  1. Para cambiar el nombre del host, haga clic con el botón derecho del ratón sobre el icono Mi equipo y seleccione Propiedades. Seleccione la pestaña Nombre del Equipo y haga clic en el botón Cambiar. Introduzca el nombre deseado para el equipo y haga clic en Aceptar. A continuación, reinicie el equipo.

  2. Compruebe que domain.tld resuelve a la misma dirección IP que la configurada en Plesk. Puede usar el siguiente comando:

    nslookup domain.tld
    

    La IP devuelta debería ser la misma que la configurada en Plesk para el dominio.

    Si el nombre de su servidor contiene menos de 15 símbolos y el dominio resuelve a la IP correcta, es posible que la configuración FTP esté dañada. Realice los pasos detallados a continuación para volver a crear la configuración de su servidor FTP:

  3. Compruebe que el usuario puede leer el contenido del directorio principal Administrador de IIS > Sitios > Haga clic con el botón secundario del ratón en <server_ip_address> > Administrar sitio FTP > Configuración avanzada > Ruta física

    alttext

    Si no es así, vuelva a configurar el sitio FTP tal y como se describe en el siguiente paso.

  4. Sólo aplicable para Parallels Panel 8 y 9: repare los permisos sobre las carpetas principales de los dominios que están experimentando el problema. Para ello puede utilizar el Panel de control: vaya a Dominios, marque el dominio que experimenta el problema y haga clic en Comprobar permisos.

    Vuelva a configurar la configuración FTP.

    • En el caso de Parallels Panel 11.0 y versiones anteriores: use la herramienta de línea de comandos ftpmng.exe de Plesk de la siguiente forma:

      "%plesk_bin%\ftpmng.exe" --remove-vhost --vhost-name=domain.tld 
      "%plesk_bin%\ftpmng.exe" --reconfigure-vhost --vhost-name=domain.tld
      
    • En el caso de Parallels Panel 11.5: use la utilidad repair.exe de la siguiente forma:

      "%plesk_cli%\repair.exe" --reconfigure-ftp-site -webspace-name domain.tld
      

    Si experimenta esta incidencia en todos los dominios, puede reparar la configuración FTP para todos los dominios mediante la ejecución de los siguientes comandos:

    • En el caso de Parallels Panel 11.0 y versiones anteriores: use la herramienta de línea de comandos ftpmng.exe de Plesk de la siguiente forma:

      "%plesk_bin%\ftpmng.exe" --remove-all
      "%plesk_bin%\ftpmng.exe" --reconfigure-all
      
    • En el caso de Parallels Panel 11.5: use la utilidad repair.exe de la siguiente forma:

      "%plesk_cli%\repair.exe" --reconfigure-ftp-sites
      

    Nota: estos comandos no afectarán a la funcionalidad de los sitios web (HTTP/HTTPS). De todos modo, se perderá cualquier configuración FTP personalizada.

  5. Abra el editor del registro (Inicio > Ejecutar > regedit), vaya a HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\PLESK\PSA Config\Config, compruebe la ruta FTP_ROOT_D y verifique que esta coincide con el directorio físico existente.

  6. Compruebe la ruta física para los sitios FTP en IIS > Sitios web > Dirección IP > Configuración básica > Ruta física. Esta debería ser parte de FTP_ROOT_D del paso anterior.

  7. Verifique que la carpeta del usuario del sistema (usuario FTP) de la suscripción está presente en ruta del sitio FTP (Vea la sección Causa). Por ejemplo, C:\inetpub\vhosts\Servers\8\localuser\system_user\domain.tld\. De no estarlo, busque la carpeta que contiene dicha carpeta, como puede ser C:\inetpub\vhosts\Servers\7\ y edite la ruta física de forma correspondiente.

  8. Verifique que el archivo de vinculación del usuario FTP C:\inetpub\vhosts\Servers\8\localuser\system_user\domain.tld\ dispone del permiso de lectura y ejecución para el usuario FTP (system_user).

Si ha experimentado alguna incidencia con el acceso FTP en el servidor Parallels Panel para Linux, consulte el siguiente artículo:

Mi servidor está detrás de un firewall. ¿Cómo puedo configurar un rango de puertos pasivos para ProFTPd?

a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF