Article ID: 5616, created on Jul 27, 2009, last review on Apr 25, 2014

  • Applies to:
  • Plesk Expand 2.x

Síntomas

Uso FedoraCore5 o FedoraCore6 y SELinux se ejecuta en modo Aplicación. No puedo instalar Plesk Expand con el Autoinstalador.
 

Cuando intento instalar Parallels Plesk Expand usando el Autoinstalador, se genera el siguiente error:

error: %trigger(expand-locale-base-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 20. Installing package checkpolicy
[AI::RPM] 21. Installing package expand-dist-repository
[AI::RPM] 22. Installing package expand-locale-de-DE
error: %post(expand-locale-de-DE-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 23. Installing package expand-locale-es-ES
error: %post(expand-locale-es-ES-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 24. Installing package expand-locale-fr-FR
error: %post(expand-locale-fr-FR-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 25. Installing package expand-locale-ja-JP
error: %post(expand-locale-ja-JP-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 26. Installing package expand-locale-ru-RU
error: %post(expand-locale-ru-RU-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 27. Installing package expand-locale-zh-CN
error: %post(expand-locale-zh-CN-2.3.2-080905.noarch) scriptlet failed, exit status 255
[AI::RPM] 28. Installing package expand-locale-zh-TW
error: %post(expand-locale-zh-TW-2.3.2-080905.noarch) scriptlet failed, exit status 255
error: %pre(expand-selinux-support-2.3.2-8.noarch) scriptlet failed, exit status 255
error: install: %pre scriptlet failed (2), skipping
expand-selinux-support-2.3.2-8

SELinux se ejecuta en modo Aplicación y usa la directiva de destino.

~# getenforce
Enforcing
~#


Tengo instalados los siguientes paquetes:

selinux-policy-2.2.23-15
selinux-policy-targeted-2.2.23-15

 

Causa

La causa del problema es la definición de una directiva SELinux de destino incorrecta por parte del paquete antiguo selinux-policy-targeted.

Resolución

Para poder instalar Plesk Expand a través del Autoinstalador en un servior con un paquete SELinux habilitado, selinux-policy-targeted debería actualizarse a la versión 2.4.6 o a una versión posterior.

También puede cambiar el modo de SELinux a Permisivo con setenforce 0 o deshabilitarlo.

Para deshabilitar SELinux, cambie su estado en /etc/selinux/conf y reinicie el servidor:

/etc/selinux/conf
....................
# This file controls the state of SELinux on the system.
# SELINUX= can take one of these three values:
#       enforcing - SELinux security policy is enforced.
#       permissive - SELinux prints warnings instead of enforcing.
#       disabled - No SELinux policy is loaded.
SELINUX=disabled
# SELINUXTYPE= can take one of these two values:
#       targeted - Only targeted network daemons are protected.
#       strict - Full SELinux protection.
SELINUXTYPE=targeted

....................


0316bb680a7c882e8693bf1bcd23642b 8760abb54be64bdc3c8805b6572624e8 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF