Article ID: 5977, created on Jun 22, 2009, last review on Apr 18, 2012

  • Applies to:
  • Plesk 9.x for Linux/Unix

Síntomas

La instalación o actualización de Parallels Plesk Panel a la versión 9.x puede experimentar errores en el servidor basado en CentOS 4.x con PostgreSQL 8.1.

En Parallels Plesk Panel aparece un error interno de servidor:

500 - Error Interno del Servidor

En el registro de error sw-cp-server aparecen los siguientes mensajes:

/var/log/sw-cp-server/error_log
.....
/usr/bin/sw-engine-cgi: symbol lookup error: /usr/bin/sw-engine-cgi: undefined symbol: PQescapeByteaConn
2009-01-08 08:16:29: (mod_fastcgi.c.1004) the fastcgi-backend /usr/bin/sw-engine-cgi failed to start:
2009-01-08 08:16:29: (mod_fastcgi.c.1008) child exited with status 127 /usr/bin/sw-engine-cgi

.....


NOTA: A partir de la versión 9.0, el servidor del CP de Parallels Plesk Panel funciona a través de sw-cp-server.

Resolución

Parallels Plesk Panel 9.0 para CentOS 4.x se distribuye con soporte de PostgreSQL 7.4.

Si se instaló PostgreSQL 8.1 desde el repositorio centosplus, también deberá actualizar las bibliotecas compatibles. Las bibliotecas que acompañan a Parallels Plesk Panel son obsoletas y puede que no se carguen correctamente.

Puede descargar los paquetes más recientes en ftp://ftp.postgresql.org/pub/binary/v8.1.15/linux/rpms/redhat/.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF