Article ID: 6153, created on Jun 30, 2009, last review on May 10, 2014

  • Applies to:
  • Plesk 10.x for Linux
  • Plesk 9.x for Linux/Unix
  • Plesk 8.6 for Linux/Unix

Síntomas

No puedo actualizar Parallels Plesk Panel usando el autoinstalador porque hay instalado el paquete de una versión más nueva.

Por ejemplo, intento actualizar a la versión 9.0.1 en SuSE10.3 y tengo instalado php5-5.2.8. En el informe de autoactualización de Parallels Plesk Panel aparece el siguiente error:

The following could cause the installation failure:
Packages "php5-5.2.6-0.6.i586 (u 0x8ba26f8 source=0x87c60b8 P:52 R:27)" and "php5-5.2.8-32.6.i586 (s 0x86d9eb8 source=0x869b7e0 P:52 R:27)" cannot be installed at the same time because of the conflict on the file "/etc/php5/cli/php.ini"

Causa

Parallels Plesk Panel 9.0.1 en SuSE10.3 fue concebido con soporte de php5-5.2.6. Esta versión se proporciona para SuSe10.3 por parte del fabricante. Puede consultar la lista de paquetes soportados en la página web del autoinstalador: http://autoinstall.plesk.com/

Seleccione su versión de Parallels Plesk Panel, sistema operativo y arquitectura. Los paquetes están en el directorio update-rpm-OS-architecture.

Por ejemplo, para SuSE10.3: http://autoinstall.plesk.com/PSA_9.0.1/update-rpm-SuSE-10.3-i386.

Se soportan paquetes de versiones más nuevas, pero el autoinstalador de Parallels Plesk Panel comprueba la disponibilidad exacta de estas versiones. Si tiene instalados paquetes anteriores, se realizará una actualización. De todas formas, el autoinstalador de Parallels Plesk Panel falla debido a un problema de dependencia si hay instalada una versión más nueva del paquete.

Resolución

Para actualizar Parallels Plesk Panel con el autoinstalador, instale los paquetes de la versión exacta proporcionada por el fabricante de su sistema operativo.

Asimismo, el autoinstalador puede intentar resolver las dependencias más nuevas a través de repositorios externos. Esto se realiza a través del archivo /root/.autoinstallerrc, tal y como se describe aquí:

http://download1.parallels.com/Plesk/Plesk9.0/Doc/en-US/plesk-9.0-unix-installation-guide/index.htm?fileName=24769.htm

Por ejemplo, puede indicar el repositorio desde el que se instalaron los paquetes PHP más nuevos ejecutando el siguiente comando:

~# echo `ADDITIONAL_SOURCE="repodata,100,http://<REPO_URL/,none,none"` > /root/.autoinstallerrc

Una vez hecho esto, puede realizar la actualización usando la herramienta Actualizador del UI de Parallels Plesk Panel {Servidor -> Actualizador} o del CLI de Parallels Plesk Panel /usr/local/psa/admin/sbin/autoinstaller.

6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 9fa0130c84cac4b292697ade62270a40 b8ef5052d936e902043e41759118114e dd0611b6086474193d9bf78e2b293040 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF