Article ID: 6561, created on Aug 3, 2009, last review on Apr 28, 2012

  • Applies to:
  • Plesk 9.x for Linux/Unix
  • Plesk 8.6 for Linux/Unix

Síntomas

Una vez actualizado el navegador Internet Explorer en una workstation a la versión 8.0, ya no se puede abrir el interfaz de Parallels Plesk Panel.

Resolución

Parallels Plesk Panel 8.6:

Encontrará una posible solución para este caso en este artículo.

Modifique el archivo config /opt/psa/admin/conf/httpsd.conf' o  '/usr/local/psa/admin/conf/httpsd.conf' en función de su instalación de "Parallels Plesk Panel" e incorpore las siguientes cadenas de texto en este archivo para forzar a IE8 a usar la representación de IE7:

LoadModule headers_module libexec/mod_headers.so
Header set X-UA-Compatible "IE=EmulateIE7"

Una vez hecho esto, reinicie el servicio principal de Parallels Plesk Panel para que se apliquen los cambios:

# /etc/init.d/psa restart

Parallels Plesk Panel 9.x:


Como Parallels Panel 9.x usa el paquete 'lighttpd', deberá aplicar los siguientes cambios:

Modifique el archivo de configuración '/etc/sw-cp-server/applications.d/plesk.conf' del servicio de Parallels Plesk Panel:

1) Añada "mod_setenv" a la lista de módulos:

Cadena de texto a modificar:
 
server.modules += ("mod_expire", "mod_fastcgi", "mod_rewrite", "mod_accesslog", "mod_alias", "mod_compress")

Una vez realizada la modificación:
 
server.modules += ("mod_expire", "mod_fastcgi", "mod_rewrite", "mod_accesslog", "mod_alias", "mod_compress","mod_setenv")

2) Una vez hecho esto, deberá moificar los hosts virtuales del CP de Parallels Plesk Panel en el mismo archivo de configuración y añadir la línea "setenv.add-response-header = ( "X-UA-Compatible" => "IE=EmulateIE7" )".

Ejemplo:

Antes de la modificación:

...
$SERVER["socket"] == ":8443" {
  include_shell "/usr/local/psa/admin/conf/ssl-conf.sh"
...
$SERVER["socket"] == ":8880" {
  index-file.names = ("index.php")
...

Después de la modificación:

...
$SERVER["socket"] == ":8443" {
  setenv.add-response-header = ( "X-UA-Compatible" => "IE=EmulateIE7" )
  include_shell "/usr/local/psa/admin/conf/ssl-conf.sh"
...
$SERVER["socket"] == ":8880" {
  setenv.add-response-header = ( "X-UA-Compatible" => "IE=EmulateIE7" )
  index-file.names = ("index.php")
...

Para que se apliquen los cambios, reinicie el servicio 'sw-cp-server':

# /etc/init.d/sw-cp-server restart
Restarting SWsoft control panels server... stale pidfile. [ OK ]

b8ef5052d936e902043e41759118114e a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 9fa0130c84cac4b292697ade62270a40 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF