Article ID: 7110, created on Mar 13, 2012, last review on Aug 12, 2014

  • Applies to:
  • Plesk 10.2 for Linux/Unix
  • Plesk 10.1 for Linux/Unix
  • Plesk 10.0.x for Linux/Unix
  • Plesk 9.5 for Linux/Unix
  • Plesk 9.3 for Linux/Unix
  • Plesk 9.2 for Linux/Unix

Aplicación de la corrección

Este problema ha sido corregido a partir de la publicación de Parallels Plesk Panel 10.3.

Síntomas

La habilidad para actualizar Parallels Panel con microactualizaciones fue implementada en Parallels Panel 9.2.3 para Linux y Parallels Small Business Panel 10.0.0 para Linux y Windows.

La implementación actual no le permite instalar microactualizaciones de forma automática si Parallels Panel para Linux se ha desplegado en los contenedor mediante plantillas de Parallels Containers.

Resolución

Este problema fue corregido en la versión 10.3. Para las versiones anteiores, use la siguiente solución provisional:

Mediante la utilidad de línea de comandos

Si desea aplicar las microactualizaciones más recientes tras el aprovisionamiento de un contenedor, es necesario ejecutar manualmente el comando que aparece a continuación dentro del contenedor o instalar las microactualizaciones mediante el GUI de Parallels Panel:
$PRODUCT_ROOT_D/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base

Personalización de la plantilla de Parallels Virtuozzo Containers

Otra solución es personalizar el script de instalación de la plantilla.

Cree un archivo post-install con el comando apropiado en el directorio de plantillas EZ de Parallels Panel.

Ejemplo para una plantilla EZ de Parallels Panel 9:
# cat /vz/template/centos/5/x86/config/app/plesk9/default/post-install
# !/bin/bash

echo "Microupdates applying"
/usr/local/psa/admin/sbin/autoinstaller --select-product-id plesk --select-release-current --reinstall-patch --install-component base --separate-logs 2>/dev/null 1>/dev/null || true

Nota: La ruta /usr/local/psa debería cambiarse en función del valor $PRODUCT_ROOT_D. El valor /usr/local/psa es apropiado para la mayoría de sistemas basados en RPM.

A continuación, establezca permisos 755 para el archivo creado:
# chmod 755 /vz/template/centos/5/x86/config/app/plesk9/default/post-install

El script se ejecutará una vez completadas todas las instalaciones de la plantilla EZ de la nueva plantilla Plesk9.

Además, es necesario crear un script post-update con el mismo contenido:
# cp /vz/template/centos/5/x86/config/app/plesk9/default/post-install /vz/template/centos/5/x86/config/app/plesk9/default/post-update

Compruebe sus permisos:
# ls -la /vz/template/centos/5/x86/config/app/plesk9/default/post-update
-rwxr-xr-x  1 root root 201 Mar 12 20:41 /vz/template/centos/5/x86/config/app/plesk9/default/post-update

Con el script post-update se pueden aplicar microactualizaciones a contenedores existentes que tengan instalado Parallels Panel 9 (mediante el comando # vzpkg update <CTID> <lista de plantillas instaladas, incluyendo plesk9>).

Ejemplo:
# vzpkg update 888 plesk9 plesk9-qmail postgresql

Información adicional

En PBAs (HSPc), las plantillas EZ se instalan por separado. Para evitar tener que rescribir los archivos de la microactualización por archivos de paquete, es necesario añadir el script post-install a todas las plantillas plesk9-* VZ. Esto puede afectar de forma crítica a la duración de la instalación.

Instalación de microactualizaciones para PPSMB para Linux: http://kb.sp.parallels.com/es/8191

Instalación de microactualizaciones para PPSMB para Windows: http://kb.sp.parallels.com/es/8190

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 165ec78c924fabffe1d80dc3eabc98c6 6ef0db7f1685482449634a455d77d3f4 11a46d8a188d618564f4f0cead9a50f3 60d3e722783ac7177a2b4b4c13af4062 dd0611b6086474193d9bf78e2b293040 d3c493291d6d9f66837ac7495dfea9ca b21de1858ad3ec50d5613195a77434ab def31538ba607bde27398f48ab5956be 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF