Article ID: 7989, created on Feb 4, 2010, last review on Apr 18, 2012

  • Applies to:
  • Virtuozzo containers for Linux 4.0

Síntomas

La instalación de paquetes devel y mod_ssl devuelve el error que aparece a continuación en un contenedor que se ha actualizado de Fedora Core 10 a 11:

--> Missing Dependency: httpd = 2.2.13-1.fc11 is needed by package httpd-devel-2.2.13-1.fc11.x86_64 (base3)
Error: Missing Dependency: httpd = 2.2.13-1.fc11 is needed by package httpd-devel-2.2.13-1.fc11.x86_64
(base3)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
Error: /usr/share/vzyum/bin/yum failed, exitcode=1

Causa

El Apache presente en Fedora 10 es más nuevo que el presente en Fedora 11 (httpd-2.2.14-1.fc10 en contraposición con httpd 2.2.13-1.fc11). Por este motivo, Apache tiene una versión más antigua una vez realizada la actualización del SO del contenedor. De todos modos, los repositorios han sido cambiados en Fedora 11 y mod_ssl de Fedora 11 requiere el Apache de Fedora 11.

Resolución

La solución a esta incidencia pasa por eliminar httpd manualmente una vez completada la actualización e instalar el Apache de Fedora 11. Esta incidencia se resolverá de forma permanente cuando Fedora actualice httpd en Fedora 11 a 2.2.14.

35c16f1fded8e42577cb3df16429c57a d02f9caf3e11b191a38179103495106f e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF