Article ID: 822, created on Jun 29, 2009, last review on May 6, 2014

  • Applies to:
  • Plesk for Linux/Unix

Resolución

El mensaje de error completo es:

Unable to make action: Unable to manage service by spamd: Empty error message from utility. 0: /usr/local/psa/admin/htdocs/server/restart_services.php:19 psaerror(string "Unable to make action: Unable to manage service by spamd: Empty error message from utility.")

Intente iniciar psa-spamassassin desde la línea de comandos:


/etc/init.d/psa-spamassassin start
Can't locate Text/Iconv.pm in @INC (@INC contains:
/usr/local/lib/perl5/5.8.7/i686-
linux /usr/local/lib/perl5/5.8.7
/usr/local/lib/perl5/site_perl/5.8.7/i686-linux
/usr/local/lib/perl5/site_perl/5.8.7 /usr/local/psa/lib/perl5/5.8.7
/usr/local/psa/lib/perl5/5.8.7/i686-linux
/usr/local/psa/lib/perl5/site_perl/5.8.7/i686-linux
/usr/local/psa/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.0
/usr/local/lib/perl5/site_perl) at
/usr/lib/perl5/site_perl/5.8.0/Mail/SpamAssassin/CmdManage.pm line 8.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.8.0/Mail/SpamAssassin/CmdManage.pm line 8.
Compilation failed in require at /usr/local/psa/admin/sbin/spammng line 71.

Este error significa que existe algún problema en el propio Perl y este no puede encontrar los módulos requeridos. Compruebe que tiene instalados todos los RPMs requeridos para 'Spamassassin'.

Compruebe la versión de Perl:

perl -v
rpm -q perl

Compruebe también la integridad del paquete con el siguiente comando:

rpm -V perl

Vuelva a instalar el RPM de Perl si las versiones indicadas por estos comandos no coinciden o si la prueba de integridad muestra algún error.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF