Article ID: 9059, created on Dec 21, 2011, last review on Aug 12, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix

Resolución

Es posible utilizar php.ini personalizado para dominios si en este se usa el modo PHP as FastCGI.

Pero para ello es necesario aplicar un hotfix. La corrección es compatible con versiones 9.x de Parallels Plesk Panel.

Use las siguientes instrucciones para aplicar el hotfix.

1. Descargue el hotfix adjunto.
# wget http://kb.sp.parallels.com/Attachments/13985/Attachments/cgi_wrapper

2. Localice el archivo cgi_wrapper
# cat /etc/psa/psa.conf |grep CGI_PHP
CGI_PHP_BIN /var/www/cgi-bin/cgi_wrapper/cgi_wrapper

3. Cree un backup de este archivo
# cp /var/www/cgi-bin/cgi_wrapper/cgi_wrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper_orig

4. Reemplace cgi_wrapper por el descargado
# cp cgi_wrapper /var/www/cgi-bin/cgi_wrapper/cgi_wrapper

5. Copie php.ini al directorio de configuración del dominio
# cp php.ini /var/www/vhosts/domain.tld/conf/

6. Cambie los permisos para el directorio de configuración del dominio
# chmod 0755 /var/www/vhosts/domain.tld/conf

7. Reinicie Apache
# /etc/init.d/httpd restart

Una vez realizados estos cambios, se usará la configuración de php.ini en el directorio de configuración del dominio.

Attachments

6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF