Article ID: 9621, created on May 18, 2012, last review on May 10, 2014

  • Applies to:
  • Panels
  • Virtuozzo containers for Linux

Síntomas

Escenario 1: En PCC, va a CT (CTID) > pestaña Aplicaciones > Desinstalar aplicaciones y selecciona plesk y sitebuilder > Desinstalar. En este momento aparece el error que puede verse a continuación.
 
No pueden eliminarse los paquetes: error: Dependencias con errores:

Error: /usr/lib/rpm/rpmi failed, exitcode=58





 
Escenario 2: En PCC, va a CT (CTID) > pestaña Aplicaciones y hace clic en Plesk y Sitebuilder > Desinstalar. En el registro de acciones aparece el mismo error.

 
Escenario 3: En CP, va a CT (CTID) > Sistema > Administración de aplicaciones > Aplicaciones y hace clic en Plesk > Desinstalar. Aquí se obtiene el mismo error.

Resolución

Parallels tiene previsto corregir esta incidencia en una de las próximas versiones.

Solución temporal:

Acceda al contenedor correspondiente mediante SSH y desinstale los paquetes con conflictos de forma manual con el siguiente comando:
 
# rpm -qa | grep “psa-hotfix\|psa-updates\|perl-MLDBM\|perl-Apache-ASP” | xargs rpm –e


Una vez desinstalados los paquetes, vuelva a PCC o a CP e intente desinstalar la aplicación de nuevo.

2897d76d56d2010f4e3a28f864d69223 caea8340e2d186a540518d08602aa065 e8e50b42231236b82df27684e7ec0beb d02f9caf3e11b191a38179103495106f 400e18f6ede9f8be5575a475d2d6b0a6 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF