Article ID: 1358, created on Mar 11, 2009, last review on Apr 29, 2014

  • Applies to:
  • Plesk 10.4 for Windows

Symptômes

Un dossier configuré comme étant protégé sur un domaine est accessible sans autorisation.

Cause

1. Le filtre ISAPI de Parallels Plesk Panel pour les répertoires protégés n'est pas configuré sur le site Web.

2. L'ID du serveur du site Web n'équivaut pas à l'ID du serveur stocké dans la base de données de Parallels Plesk Panel.

3. Mauvaise configuration
dans la base de données de Parallels Plesk Panel.

Résolution

. Vérifiez si le filtre ISAP urlprotect.dll est activé sur un site Web dans IIS.
IIS, Sites Web, domain.com, Clic droit, Propriétés, Filtres ISAPI, urlprotect.dll

2. Vérifiez le site Web dans IIS.

IIS, Sites Web, Trouver le site Web problématique dans la liste, Identificateur est à droite du nom du site. Ou utilisez l'utilitaire en ligne de commande

"%plesk_bin%\websrvmng" --get-server-id --vhost-name=domain.com
Puis vous devez vérifier l'id du serveur dans la BD de Parallels Plesk Panel


select server_id from hosting h, domains d where h.dom_id=d.id and d.name='domain.com';
Si les valeurs reçues ne sont pas équivalentes, vous devez les synchroniser.

"%plesk_bin%\websrvmng" --update-all-server-id


 Puis redémarrez le Service de gestion de Parallels Plesk Panel.

3. Si les deux étapes précédentes n'ont pas aidé, vérifiez la table `protected_dirs` dans la BD de Parallels Plesk Panel. Il ne doit y avoir aucun enregistrement avec une valeur vide dans le champ Chemin d'accès.

select * from protected_dirs where path='';
Si des rows ont été retournés, ils doivent être supprimés.

delete from protected_dirs where path='';

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