Article ID: 1770, created on Feb 10, 2009, last review on May 11, 2014

  • Applies to:
  • Plesk for Windows

Résolution

Cet article décrit les versions de PHP qui peuvent être utilisées dans Parallels Plesk Panel et la configuration recommandée des fichiers php.ini.

Il y a deux versions de PHP comprises et prises en charge par Parallels Plesk Panel : PHP4 et PHP5. PHP peut fonctionner en deux modes : en tant que CGI ou  ISAPI. Les deux versions de PHP utilisent les fichiers php.ini qui sont différents en fonction de la version du PHP.

L'emplacement par défaut de php.ini pour PHP4 est un répertoire de base Windows %systemroot%.

L'emplacement par défaut de php.ini pour PHP5 est un répertoire de base PleskPHP5 %plesk_dir%Additional\PleskPHP5

Un php.ini personnalisé avec PHP4 en mode CGI peut être utilisé. Afin de l'appliquer, le fichier php.ini doit être placé dans le dossier /httpdocs.

Mais il n'y a pas d'option de ce type avec PHP4 en mode ISAPI qui utilise toujours le php.ini par défaut de PHP4. De même, c'est impossible avec PHP5 dans les deux modes si le php.ini par défaut de PHP5 est utilisé.

L'emplacement par défaut du fichier php.ini dans PHP5 est défini par la valeur suivante dans le registre :

HKEY_LOCAL_MACHINE\SOFTWARE\PHP\5\IniFilePath

Informations supplémentaires

Consultez l'article pour en savoir plus sur les différences entre les modes ISAPI et CGI :

http://msdn2.microsoft.com/en-us/library/ms525172.aspx

85a92ca67f2200d36506862eaa6ed6b8 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF