Article ID: 1812, created on Feb 18, 2009, last review on Apr 17, 2012

  • Applies to:
  • Plesk Sitebuilder 4.5 for Linux/Unix

Résolution

 Liste des pré-requis que vous pouvez trouver sur notre site Web ici :
http://www.swsoft.com/fr/products/sitebuilder/reqs/

Il existe un script spécial qui peut vous aider à vérifier si tout est en accord avec les pré-requis : SITEBUILDER_ROOT/resources/publish/check.php. Il doit être exécuté à partir du répertoire du site de publication. Par exemple, si vous essayez de publier vers le domaine domain.tld, vous devez envoyer ce script dans le répertoire du site et l'exécuter dans le navigateur en tant que http://domain.tld/check.php.

Par exemple, vous pouvez trouver la sortie correcte ci-dessous :

 ioncube=ok phpVersion=4.4.3 mbstring=ok zlib=ok session=ok dom=ok domxml_xslt=ok sqlite=2.8.17 sqliteEncoding=UTF-8 gd_png=ok gd_gif=ok gd_jpg=ok gd_wbmp=ok gd=2.0.28 safe_mode=ok mail=ok serverApi=Apache  Handlerfolder_permissions_data=ok


REMARQUE :
 1.
La publication fonctionne avec safe_mode 'activé' à partir de la version 4.0. Donc, si vous avez la version 4.0 ou une version ultérieure, vous n'avez pas besoin de vous inquiéter sur la sortie safe_mode=failed.
 2. Le paramètre folder_permissions_data est pour publier vers les serveurs Windows. Si vous voyez folder_permissions_data=fail, vous pouvez ignorer cette sortie.

Informations supplémentaires

SITEBUILDER_ROOT - Le répertoire d'installation de Parallels Plesk Sitebuilder /usr/local/sitebuilder/ ou /opt/sitebuilder/ sur les serveurs Debian/Ubuntu.

fad6dc0c8e983c17ae70a51ac7952cd0 56797cefb1efc9130f7c48a7d1db0f0c f7f840260c1591440648a375a64b5b75 d055be4fdc562a8ecb8e6d0bf419f946 ea6a61e571a858aa6019ceb068ea403a

Email subscription for changes to this article
Save as PDF