Article ID: 3546, created on May 8, 2009, last review on Apr 22, 2012

  • Applies to:
  • Plesk for Linux/Unix

Symptômes

La mise à niveau ou l'installation de Parallels Plesk Panel sur CentOS a échoué avec cette erreur dans la console :

ERROR while trying to install initial Plesk database

Le log d'installation affiche :

Trying to install initial Plesk database... ERROR 1064 (42000) at
line 2: You have an error in your SQL syntax; check the manual that
corresponds to your MySQL server version for the right syntax to use near
'----------------------------------------' at line 1

Cause

La version 5.0.54 de MySQL n'accepte plus de lignes de commentaires SQL qui commencent par '--', et qui n'ont pas d'espace blanc ou de caractère de contrôle après la chaîne '--'.  Cela fonctionnait dans les précédentes versions MySQL même si l'équipe MySQL a déclaré explicitement qu'elle n'a pas été prise en charge (http://dev.mysql.com/doc/refman/5.0/en/ansi-diff-comments.html).

Résolution

Prenez les précédents mysql* rpms du répertoire centosplus, comme http://mirror.centos.org/centos/4/centosplus/i386/RPMS/  et rétrogradez mysql vers une version antérieure, par exemple 5.0.48. Puis exécutez de nouveau l'installation/la mise à niveau de Parallels Plesk Panel. Ce problème sera résolu dans les prochaines versions de Parallels Plesk Panel.

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF