Article ID: 3954, created on Apr 11, 2009, last review on May 12, 2015

  • Applies to:
  • Plesk 12.0 for Linux

Symptômes

Le serveur SMTP (Qmail) a le statut Inactif sur la page Gestion de services dans Plesk. Le service Qmail est disponible et les mails sont envoyés avec un délai.

Cause

SMTP ne renvoie pas de réponse immédiatement comme requis par le vérificateur de statut. Exécutez la commande suivante pour vérifier le délai de réponse :

[root@host ~]# time telnet localhost 25
 Trying 127.0.0.1...
 Connected to localhost.localdomain (127.0.0.1).
 Escape character is '^]'.
 quit
 220 your.plesk.server.hostname ESMTP
 221 your.plesk.server.hostname
 Connection closed by foreign host.
real    2m31.285s
 user    0m0.002s
 sys     0m0.001s
 [root@host ~]#

Un délai si long peut être dû à la configuration des serveurs DNSBL dans Plesk :

Accueil > Paramètres du serveur de messagerie > Activer la protection anti-spam basée sur la liste noire de DNS :

 address1;address2;address3;address4;address5;address6

Résolution

Vérifiez si tous les serveurs RBL répondent rapidement et s'ils sont résolus depuis le serveur Plesk. Si certains ne fonctionnent pas comme prévu, supprimez-les.

Infos supplémentaires

Le statut du service SMTP peut également être Arrêté si le port 25 est fermé pour les connexions locales par un pare-feu. Vérifiez si le port est ouvert :

 # telnet localhost 25
 Trying 127.0.0.1...
 Connected to localhost.
 Escape character is '^]'.
 220 your.plesk.server.hostname ESMTP

Si le résultat suivant s'affiche, cela signifie que le port est fermé. Vous devrez reconfigurer le pare-feu pour ouvrir le port :

 # telnet localhost 25
 Trying 127.0.0.1...

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7

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