Article ID: 5197, created on May 8, 2009, last review on Apr 17, 2012

  • Applies to:
  • Plesk for Linux/Unix

Symptômes

L'erreur suivante se produit lors de la restauration de la sauvegarde sur Parallels Plesk Panel Plesk 8.0 sur Parallels Plesk Panel 8.3 à l'aide de l'utilitaire /usr/local/psa/bin/pleskrestore :

Node migration-dump does not have attribute dump-version

Résolution

Notez que ce problème a été résolu dans Parallels Plesk Panel 8.4. Si vous ne pouvez pas mettre à niveau directement, vous pouvez suivre la solution ci-dessous.

Le fichier de sauvegarde doit être réparé manuellement. Ouvrez-le dans l'éditeur de texte ('vi' est préférable car il ne reformate pas le fichier ce qui pourrait corrompre le fichier) et ajoutez 'dump-version="8.3.0"' à la ligne du node 'migration-dump' avant l'édition :

<migration-dump agent-name="PleskX">

après :

<migration-dump agent-name="PleskX" dump-version="8.3.0">

Donc, 'Content-Length' de 'dump.xml' doit être augmentée par le nombre de caractères ajoutés (dans notre cas 21), avant d'éditer :

Content-Length: 12269

après :

Content-Length: 12291

Maintenant, essayez de restaurer de nouveau la sauvegarde.

29d1e90fd304f01e6420fbe60f66f838 a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF