Article ID: 5717, created on Mar 6, 2009, last review on Apr 16, 2012

  • Applies to:
  • Plesk 10.x for Linux
  • Plesk 9.x for Linux/Unix

Symptômes

Parallels Plesk Panel version 8.x ne permet pas de créer des clients avec le nom de login admin mais la création d'un client avec le nom de login tel qu'Admin (en lettres capitales) est possible. Cela pausera-t-il des problèmes dans Parallels Plesk Panel ?

Cause

Si le client  Parallels Plesk Panel portant le nom de login similaire à Admin existe, après la mise à niveau vers Parallels Plesk Panel v9, l'administrateur (admin) ne pourra pas utiliser le panneau de contrôle.

Résolution

Il faut renommer le login du client avant la mise à niveau. Vous pouvez le faire via

Parallels Plesk Panel -> Clients -> CLIENT -> Edit ->

Changez le nom de login et cliquez sur OK pour confirmer le changement.

Sinon, vous pouvez trouver le compte client portant un tel login qui peut être changé par un autre dans la base de données de Parallels Plesk Panel, par ex :

mysql> SELECT id, cname, pname, login FROM clients WHERE login LIKE 'admin';
+----+----------- +------------+-------+
| id | cname      | pname      | login |
+----+------------+------------+-------+
| 21 | ClientName | ClientName | Admin |
+----+------------+------------+-------+

mysql> UPDATE clients SET login = 'otherlogin' where ID = 21;


6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 dd0611b6086474193d9bf78e2b293040 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF