Article ID: 5875, created on Mar 2, 2009, last review on Apr 16, 2012

  • Applies to:
  • Plesk 9.0 for Linux/Unix

Symptômes

La mise à niveau de Parallels Plesk Panel 9.0 échoue avec l'erreur de dépendance ci-dessous
.
Par exemple :
Installing the package psa-mail-driver-common-9.0.0-fc8.build90081117.17.i586,
psa-9.0.0-fc8.build90081117.17.i586,
psa-libpam-plesk-9.0.0-fc8.build90081117.17.i586,
psa-mail-qc-driver-1.0.0-fc8.build90081117.17.i586,
psa-locale-base-en-US-9.0.0-08111414.noarch,
psa-api-9.0.0-fc8.build90081208.07.noarch, plesk-skins-9.0.0-0.278956.noarch,
psa-manual-custom-skin-guide-9.0.0-fc8.build90081117.17.noarch,
psa-api-rpc-9.0.0-fc8.build90081208.07.noarch,
psa-updates-9.0.0-fc8.build90081208.07.noarch,
psa-migration-manager-9.0.0-fc8.build90081208.07.i586,
psa-watchdog-2.0.3-fc8.build90081117.17.i586,
psa-backup-manager-9.0.0-fc8.build90081208.07.i586
error: Failed dependencies:
        psa-hotfix4-8.6.0 = 8.6.0 is needed by (installed) psa-hotfix5-8.6.0-8.6.0-fc8.build86080930.03.i586
ERROR: Unable to install the requested packages because of package dependency problems.
Warning! Not all packages were installed.
Please check if your system services are operable.
Please, contact product technical support.

Résolution

Le problème peut apparaître lorsque vous mettez à niveau à partir de Parallels Plesk Panel 8.6.0 vers la toute première version de Parallels Plesk Panel 9.0.0. Le problème a été corrigé dans le hotfix 9.0.0.2, veuillez utiliser les builds 9.0 disponibles pour la mise à niveau du panneau.

Sinon, vous pouvez désinstaller manuellement le pack psa-hotfix5-8.6.0 avec rpm -e --nodeps puis procéder à la mise à niveau.

4f57df935e9acf8d18830757d2346419 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF