Article ID: 6074, created on Feb 25, 2009, last review on Aug 12, 2014

  • Applies to:
  • Plesk 9.0 for Linux/Unix

Symptômes

Parallels Plesk Panel version 9.0.x est installée et Postfix MTA est utilisé.

Impossible d'envoyer des mails avec des pièces jointes à partir du serveur. L'erreur suivant s'affiche dans le log de la messagerie
$PRODUCT_ROOT_D/var/log/maillog :

Dec 18 18:28:45 plesk before-queue[1331]: handlers_stderr: PASS
Dec 18 18:28:45 plesk before-queue[1331]: errno: Broken pipe
Dec 18 18:28:45 plesk before-queue[1331]: System error: Broken pipe
Dec 18 18:28:45 plesk before-queue[1331]: Unable to write data to stream
Dec 18 18:28:45 plesk before-queue[1331]: Some error occured
Dec 18 18:28:45 plesk postfix/spawn[919]: warning: command
/usr/lib64/plesk-9.0/postfix-queue exit status 255


Comment puis-je résoudre ce problème ?

Résolution

Ce problème est connu. Il sera réglé dans la prochaine mise à jour de Parallels Plesk Panel.

Vous pouvez trouver ci-joint le hotfix pour la version 9.0.x. Pour l'installer, vous devez télécharger l'archive et la dézipper avec tar -zxf.
Dans le répertoire obtenu, trouvez le fichier postfix-queue approprié pour votre système d'exploitation et votre architecture.
Remplacez le fichier existant postfix-queue par celui que vous avez trouvé. Le fichier est situé dans le répertoire
$PLESK_LIBEXEC_DIR.

N'oubliez pas de corriger la propriété et les droits. Il doit s'agir de mhandlers-user:popuser, 550.

Vous pouvez corriger les droits à l'aide des commandes chown et chmod. Par exemple pour CentOS5, 32bit :

~# chown mhandlers-user:popuser /usr/lib/plesk-9.0/postfix-queue
~# chmod 550 /usr/lib/plesk-9.0/postfix-queue

Attachments

4f57df935e9acf8d18830757d2346419 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 6ef0db7f1685482449634a455d77d3f4 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF