Article ID: 6434, created on Jan 12, 2010, last review on Apr 19, 2012

  • Applies to:
  • Virtuozzo containers for Windows
  • Virtuozzo containers Tools

Symptômes

La section 'Log de trafic' n'affiche pas les données dans Parallels Power Panel.

Cause

Cela peut s'expliquer par une limite de mémoire trop faible configurée pour le serveur MSSQL fonctionnant dans le conteneur de service sur le serveur Parallels Virtuozzo Containers pour Windows et par conséquent, il ne peut pas traiter correctement les requêtes à partir de VZAgent

Résolution

Pour résoudre ce problème, vous devez vous connecter au serveur Virtuozzo par RDP et exécutez les actions suivantes :

1. Ouvrez l'outil de la ligne de commande : Démarrer > Exécuter> cmd

2. Entrez le conteneur de services : vzctl enter 1

3. Lancez l'outil osql.exe :
"%ProgramFiles%\Microsoft SQL Server\80\Tools\Binn\osql.exe" -E

4. Changez la limite de la mémoire MSDE comme suit :
sp_configure 'max server memory (MB)',512
go
reconfigure
go


Cette action augmentera la limite de la mémoire pour le serveur MSSQL et cela permettra au serveur MSSQL de récupérer les statistiques du trafic à partir de la base de données.

Vous pouvez également installer MSSQL Management Studio dans le VPS (MSXML et .NET également requis), vous y connecter par RDP et augmenter la limite de la mémoire à l'aide du GUI :

- exécutez MSSQL Management Studio
- cliquez avec le bouton droit de la souris le serveur MSSQL tout en haut du volet gauche
- choisissez 'Propriétés'
- cliquez sur la section 'Mémoire' dans le volet gauche de la fenêtre ouverte
- augmentez le paramètre 'Mémoire du serveur maximum (en Mo)' sur 512
- cliquez sur 'OK'

dec9992cb67244932723f716e20b57d9 d02f9caf3e11b191a38179103495106f 965b49118115a610e93635d21c5694a8 2897d76d56d2010f4e3a28f864d69223

Email subscription for changes to this article
Save as PDF