Article ID: 6588, created on Aug 17, 2009, last review on May 6, 2014

  • Applies to:
  • Plesk 9.x for Linux/Unix

Symptômes

Après l'installation ou la mise à niveau de Parallels Plesk Panel vers la version 9.2 sur une installation SuSE, YaST ne démarre plus :

~# yast
//sbin/yast: line 27: //lib/YaST2/bin/yast2-funcs: No such file or directory
//sbin/yast: line 250: set_lang_from_sysconfig: command not found
//sbin/yast: line 279: check_ncurses: command not found
package yast2-qt is not installed
package yast2-gtk is not installed  
Something is wrong with the YaST user interface.


 

Cause

La variable du systèe $PATH est modifié lors de l'installation du pack psa-courier-imap de sorte que des doubles slashs (//) sont inclus. YaST n'est pas capable d'interpréter les slashs dans la variable du système $PATH et crashe. 

Résolution

C'est un problème connu qui sera résolu dans une prochaine version de Parallels Plesk Panel. Pour le moment, une "solution" est disponible et consiste à remplacer les doubles slashs (//) par un simple slash (/) dans la variable du système $PATH et à supprimer tout chemin répété. Par ex. :

PATH = /usr/kerberos/sbin:/usr/kerberos/bin://sbin://bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

doit être remplacé par :

PATH = /usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

De plus, assurez-vous d'installer les packs manquant qui sont indiqués dans le message d'erreur. Dans le cas présent, il s'agit de yast2-qt et de  yast2-gtk.

6ef0db7f1685482449634a455d77d3f4 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF