Article ID: 967, created on Jan 30, 2009, last review on Apr 29, 2014

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix

Résolution

REMARQUE : Depuis Parallels Plesk Panel 8.2.0, jusqu'à 900 domaines peuvent être hébergés sur le build Apache du vendeur d'OS sans la recompilation des packs du système, décrit dans cet article, si la fonction Logs corrompus est activée sur le serveur Parallels Plesk Panel, voir 2066.


Ajoutez les lignes suivantes à /etc/sysctl.conf :

fs.file-max = 65536

Exécutez la commande shell suivante :
/sbin/sysctl -w fs.file-max=65536

Notez que la valeur fs.file-max peut être égale à 220=1048576).

Ajoutez la ligne suivante au début de /etc/init.d/apache2 et  /usr/sbin/apache2ctl:

ulimit -n `cat /proc/sys/fs/file-max`

Changez la valeur de  __FD_SETSIZE dans les fichiers /usr/include/bits/typesizes.h et /usr/include/nptl/bits/typesizes.h. Voici à ce que cela doit ressembler :

#define __FD_SETSIZE 65536

Téléchargez et recréez les packs :
# apt-get install apt-src
# apt-src --build install openssl
# dpkg -i libssl*.deb openssl*.deb
# apt-src --build install apache2
# dpkg -i libapr*.deb apache2_*.deb apache2-common*.deb apache2-mpm-prefork*.deb apache2-utils*.deb
# cp /opt/psa/suexec/psa-suexec2 /usr/lib/apache2/suexec2 /etc/init.d/apache2 restart
# apt-src --build install libc-client2002edebian
# dpkg -i libc-client-dev_2002edebian1-*.deb libc-client2002edebian*.deb mlock*.deb
# apt-src --build install php4
# dpkg -i `ls *deb|grep php4|grep -v apache-mod`


Pour Debian :
# apt-src --build install libc-client2002edebian
# dpkg -i libc-client-dev_2002edebian1-*.deb libc-client2002edebian*.deb mlock*.deb
# apt-src --build install php4
# dpkg -i `ls *deb|grep php4|grep -v apache-mod`

Pour Ubuntu 10.04 :
#apt-src --build install libc-client2007e
#dpkg -i libc-client2007e-dev*.deb libc-client2007e*.deb mlock*.deb
#apt-src --build install php5
#dpkg -i `ls *deb|grep php5 | grep -v apache-mod`


Pour savoir comment empêcher vos packs recréés d'être écrasés lors la mise à jour du système, vous pouvez trouver des infos dans cet article :

http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.en.html#s-pin

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 aea4cd7bfd353ad7a1341a257ad4724a 0a53c5a9ca65a74d37ef5c5eaeb55d7f 01bc4c8cf5b7f01f815a7ada004154a2 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040

Email subscription for changes to this article
Save as PDF