Article ID: 114601, created on Oct 17, 2013, last review on May 11, 2014

  • Applies to:
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Sintomi

L'applicazione FastCGI  eil modulo Apache  sono entrambi esclusi dal supporto PHP ((dal menu a discesa nella pagina Impostazioni di hosting). Qui è elencata solo l'applicazione CGI .

Qual è la causa del problema e come è possibile risolverlo?

Causa

Parallels Plesk Panel viene eseguito in modalità ottimizzata VPS:

~# /usr/local/psa/bin/vps_optimized --status
VPS Optimized mysql-innodb: OffVPS Optimized apache-modules-all: on
VPS Optimized apache-modules-except-php: off
VPS Optimized apache-modules-except-scripting: off
~#


In tale modalità, PHP può essere eseguito esclusivamente come "applicazione CGI":

~# /usr/local/psa/bin/domain --update DOMAIN.TLD -php_handler_type module
WARNING: mod_php is disabled because the Panel operates in the VPS-optimized mode.module is disabled because the Panel operates in the VPS-optimized mode.
SUCCESS: Update of domain 'DOMAIN.TLD ' completed.
~#

~# /usr/local/psa/bin/domain --update DOMAIN.TLD  -php_handler_type fastcgi
WARNING: mod_php is disabled because the Panel operates in the VPS-optimized mode.fastcgi is disabled because the Panel operates in the VPS-optimized mode.
SUCCESS: Update of domain 'DOMAIN.TLD ' completed.
~#

Soluzione

Riattivare la modalità di funzionamento normale di Parallels Plesk Panel generando la seguente query SQL:

~# mysql -uadmin -p`cat /etc/psa/.psa.shadow` psa -e "update misc set val='0' where param='vps_optimized_mode_status';"

Per informazioni dettagliate, fare riferimento alla Guida di amministrazione avanzata per Parallels Plesk Panel 11.

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 aea4cd7bfd353ad7a1341a257ad4724a 01bc4c8cf5b7f01f815a7ada004154a2

Email subscription for changes to this article
Save as PDF