Article ID: 115779, created on Apr 17, 2013, last review on May 10, 2014

  • Applies to:
  • Plesk 11.0 for Linux

Sintomi

Il passaggio del maildriver da Qmail verso Postfix utilizzando l'Autoinstaller restituisce errore su RHEL/CentOS - 6.4, come ad esempio:
 
Attempt to remove 'plesk-mail-qc-driver' to resolve conflict has succeeded
No package matched to remove: psa-qmail-rblsmtpd-0.88-rhel6.build110120606.19.i386
Attempt to remove 'psa-qmail-rblsmtpd-0.88-rhel6.build110120606.19.i386' to resolve conflict has failed
...
No package matched to remove: 2:psa-qmail-1.03-rhel6.build110120606.19.i386
Attempt to remove '2:psa-qmail-1.03-rhel6.build110120606.19.i386' to resolve conflict has failed
...
Exception: Failed to solve dependencies:
plesk-mail-pc-driver conflicts with psa-qmail-rblsmtpd-0.88-rhel6.build110120606.19.i386
plesk-mail-pc-driver conflicts with 2:psa-qmail-1.03-rhel6.build110120606.19.i386

ERROR: The Yum utility failed to install the required packages.
Attention! Your software might be inoperable.
Please, contact product technical support.

Causa

L'Autoinstaller non riesce a rimuovere i pacchetti psa-qmail e psa-qmail-rblsmtpd utilizzando yum. Il problema è correlato al pacchetto yum che è stato aggiornato nella release di RHEL/CentOS-6.4. Nei prossimi aggiornamenti (#132413), aggiorneremo il modo di funzionamento con yum in modo da risolvere il problema.

Soluzione

Rimuovi i pacchetti in conflitto psa-qmail e psa-qmail-rblsmtpd, ignorando le dipendenze:
# rpm -e psa-qmail psa-qmail-rblsmtpd --nodeps

Dopodiché, esegui l'Autoinstaller nuovamente per installare il componente Postfix.

aea4cd7bfd353ad7a1341a257ad4724a 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f

Email subscription for changes to this article
Save as PDF