Article ID: 116050, created on Jan 14, 2014, last review on Aug 12, 2014

  • Applies to:
  • Plesk for Windows

Sintomi

I tentativi di gestire i database MySQL dei clienti producono gli errori:

Error: Connection to the database server has failed because of network problems: Try to establish connection failed

Il server MySQL è contrassegnato in colore rosso sullo schermo Strumenti e impostazioni > Server Database.

Causa

Questo problema potrebbe essere causato dal fatto che Parallels Plesk Panel memorizzi una password amministratore del server MySQL non valida.

Soluzione

Per risolvere il problema e riconnettere Parallels Plesk Panel al server MySQL, seguire i passaggi seguenti:

  1. Arresta il server MySQL (ma non "Plesk SQL Server") dall'esecuzione sulla porta 3306 mediante l'utility Plesk Services Monitor.

  2. Modifica il file di configurazione di MySQL, %plesk_dir%\Databases\MySQL\Data\my.ini e aggiungi la riga skip-grant-tables alla sezione [mysqld].

  3. Avvia il server MySQL.

  4. Accedi a MySQL senza la password:

    "%plesk_dir%\Databases\MySQL51\bin\mysql.exe"
    
  5. Cambia la password per l'amministratore MySQL:

    UPDATE mysql.user SET Password = password('newpassword') WHERE User = 'admin';
    
  6. Rimuovi skip-grant-tables dal file di configurazione MySQL e riavvia il servizio.

  7. Accedi all'interfaccia di Parallels Plesk Panel, vai alle impostazioni di gestione del server database (Strumenti e impostazioni > Server Database) e cambia la password per il server database adatto in modo che sia quella definita nel passaggio 5. Parallels Plesk Panel ristabilirà la connessione al server.

Per lo stesso problema sul server Linux, si consiglia la lettura di questo articolo

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8

Email subscription for changes to this article
Save as PDF