Article ID: 122706, created on Mar 17, 2015, last review on Apr 21, 2015

  • Applies to:
  • Plesk 12.5 for Windows
  • Plesk 12.0 for Windows

Sintomi

Durante l'accesso al pannello come amministratore, compare il messaggio di errore 'Access denied'. Di seguito, un esempio dell'errore da php_error.log:

Exception: Access is denied.
file: C:\Program Files (x86)\Parallels\Plesk\admin\plib\Lock\Manager\Hierarchical.php
line: 105
code: 0
trace: #0 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Lock\Manager\Hierarchical.php(105): LockManagerClient->__construct()
#1 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Lock\Manager\Hierarchical.php(172): Plesk\Lock\Manager_Hierarchical->_getClient()
#2 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Lock\Manager\Hierarchical.php(136): Plesk\Lock\Manager_Hierarchical->_applyLock('', Object(Plesk\Lock\Resource))
#3 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Lock\Manager.php(80): Plesk\Lock\Manager_Hierarchical->lock(Object(Plesk\Lock\Resource), '')
#4 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Lock.php(34): Plesk\Lock\Manager->lock(1, Array, '', Array)
#5 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Db\Table\Dictionary\ServiceNodeEnvironment.php(80): Plesk\Lock::write(Object(Plesk\Lock\Object_NodeService), '', Array)
#6 C:\Program Files (x86)\Parallels\Plesk\admin\plib\Service\Driver\Packages\Windows.php(98): Db_Table_Dictionary_ServiceNodeEnvironment->sync(false)
#7 C:\Program Files (x86)\Parallels\Plesk\admin\htdocs\login_up.php3(85): Service_Driver_Packages_Windows->sync()
#8 {main}

Causa

  • Permessi non validi sulla cartella %ProgramData%\boost_interprocess.
  • Permessi non validi su "%plesk_dir%"\var\locks\container_locks
  • Problema di Plesk php_lock_manager.dll. È stato risolto dal microaggiornamento Parallels Plesk 12.0.18 MU#34

Risoluzione

  1. Disabilita php_lock_manager.dll in Plesk %plesk_dir%\admin\conf\php.ini:

    [php_lock_manager]
    ;extension=php_lock_manager.dll
    
  2. Accertati che Plesk sia disponibile senza errori. In caso affermativo, decommenta php_lock_manager.dll come prima.

  3. Arresta il pool dell'applicazione di Plesk e installa i microaggiornamenti Plesk più recenti:

    >%systemroot%\system32\inetsrv\appcmd list apppool | findstr plesk
    APPPOOL "plesk(default)(4.0)(pool)" (MgdVersion:v4.0,MgdMode:Integrated,state:Started)
    >appcmd recycle apppool plesk(default)(4.0)(pool)
    >"%plesk_bin%"\ai.exe --select-product-id panel  --select-release-current --reinstall-patch --install-component base
    

Se la soluzione non è stata di aiuto, usa la seguente soluzione:

  • concedi i permessi 'read/write' all'utente psaadm sulle cartelle '%ProgramData%' e '%ProgramData%\boost_interprocess'.
  • concedi i permessi 'read/write' all'utente psaadm su C:\Program Files (x86)\Parallels\Plesk\var\locks\container_locks

Il riavvio è richiesto per riflettere le modifiche sul server.

ed7be2b984f9c27de1d2dc349dc19c6d 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 a766cea0c28e23e978fa78ef81918ab8 8b661cab116c79dbe6c4ac5bbdf1c8cb

Email subscription for changes to this article
Save as PDF