Article ID: 114640, created on Aug 6, 2013, last review on May 11, 2014

  • Applies to:
  • Plesk 11.x for Linux

症状

centos-6-x86_64 OS テンプレートベースの Parallels Virtuozzo Containers(PVC)コンテナに Parallels Plesk Panel(PP)11.0.9 を自動インストーラでインストールできません。この原因は、yum がインストールされていないためです。以下のエラーが表示されます。


ERROR:The Yum utility is not installed in your system.
Not all packages were installed.
Please resolve this issue and try installing the packages again.
If you cannot resolve the issue on your own, contact product technical support for assistance.

 

(Yum ユーティリティがシステムにインストールされていません。 一部のパッケージがインストールされませんでした。
この問題を解決して、パッケージのインストールをやり直してください。
問題をご自分で解決できない場合には、製品のテクニカルサポートまでご相談ください。)


原因

Parallels は、サードパーティ製コンポーネント(Apache、Perl など)や CentOS 6 用のシステムパッケージのアップデートを提供せず、OS ベンダーの提供するパッケージを利用しています。CentOS 6 に Parallels Plesk Panel をインストールするためには、Yum パッケージマネージャをインストールし、構成する必要があります。インストールせずに PP のインストールを試みると、Parallels インストーラで次のエラーメッセージが表示されます。

ERROR:The Yum utility is not installed in your system.

CentOS 6 用の EZ テンプレート pp10 および pp11 では、依存関係によって Yum がインストールされるため、Parallels インストーラは正しく機能します。

~# vzpkg install CTID pp11

ところが、コンテナ内に Parallels Plesk Panel を最初にインストールするときに、EZ テンプレートの代わりにウェブサイトから Parallels インストーラをダウンロードして使用する場合には、Yum パッケージマネージャのインストールと構成を手動で行う必要があります。

解決策

Yum パッケージをコンテナにインストールします。これには、ハードウェアノードで次のコマンドを実行します。

~# vzpkg install -p CTID yum

CTID は、PP 11.0.9 をインストールした PVC コンテナの ID に置き換えます。)

0a53c5a9ca65a74d37ef5c5eaeb55d7f 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838

Email subscription for changes to this article