Article ID: 116344, created on Jul 22, 2013, last review on Aug 12, 2014

  • Applies to:
  • Plesk 11.5 for Windows

症状

Panel から[Tools & Settings]>[Updates and Upgrades]または[Home]>[Add or Remove Components]を選択して Parallels インストーラを開こうとすると、以下のエラーで失敗します。

Execution failed.
Command: ai.exe Arguments:Array ( [0] => --service-mode=components [1] => --enable-xml-output [2] => --ssl-cert [3] => C:\Program Files (x86)\Parallels\Plesk\admin\conf\httpsd.pem [4] => --branch [5] => release,stable )
Details: file does not exist or is not executable

他の症状としては、サーバがしばらく更新されず、新規アップデートが提供されたという通知もありません。

原因

この問題は、Parallels インストーラのバイナリ(ai.exe)が存在しないことが原因で起こります。

解決策

Parallels インストーラのバイナリを Parallels ウェブサイトからダウンロードし、%plesk_bin% ディレクトリ(例:C:\Program Files (x86)\Parallels\Plesk\admin\bin)に保存します。

次に、Plesk Reconfigurator(再構成ユーティリティ)を実行し、Plesk ファイルのパーミッションを修正します([Plesk Reconfigurator]>[Repair Plesk Installation]>[Plesk File Security])。

46a8e394d6fa13134808921036a34da8 56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 bd7fc88cf1b01f097749ae6f87272128

Email subscription for changes to this article