Article ID: 111198, created on Jan 11, 2012, last review on Oct 24, 2014

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux
  • Plesk 10.4 for Linux/Unix

Симптомы

Parallels Plesk отправляет уведомление о задержке обновления ключа (см. ниже) даже после установки действительного ключа лицензии Parallels Plesk:

Subject: Parallels Plesk Panel key update deferral notification
Unable to update. An error occurred while processing your key. You can try to update it later.

Причина

Скрипт ежедневного обслуживания Parallels Plesk устанавливает соединение с сервером лицензий Parallels и выполняет регулярное обновление лицензии на основе текущей даты и времени последнего обновления, указанного в файле /etc/sw/keys/registry.xml. В случае успешной операции в файл /etc/sw/keys/registry.xml записывается новое время обновления лицензии. В случае неудачи отправляется вышеупомянутое уведомление.

Данную проблему можно устранить с помощью прикрепленного к этой статье скрипта test.php. Загрузите этот файл на свой сервер и запустите согласно следующему примеру:

# /usr/local/psa/bin/sw-engine-pleskrun -f ./test.php
Result code: 2
Description: Key update disabled
Status update: Not required

Вывод этого скрипта показывает, что обновление срока жизни лицензии отключено (и действительно - на сервере установлена пробная лицензия) и дальнейшее обновление статуса лицензии не требуется.

Примечание. Файл test.php использует фреймворк из установки Parallels Plesk и не требует никаких внешних зависимостей.

После установки Plesk 10.4.4 MU#13 ошибки, связанные с обновлением ключа, всегда записываются в файл /usr/local/psa/admin/logs/panel.log.

Если вы хотите, чтобы в журнал записывались обновления ключа, выполненные без ошибок, добавьте в файл /usr/local/psa/admin/conf/panel.ini следующие строки:

[log]
 priority = 7

Если установленная на сервере лицензия Parallels Plesk содержит PowerPack, то в файле panel.log может присутствовать следующая ошибка:

Notify: Unable to update . An error occurred while processing your key. You can try updating it later.
Result code: 2 Preparation error
Result desc: Product "kav-unix" not installed

В этом случае поместите файл key-handler.so (различается для Parallels Plesk 10.4 и 10.0-10.3) из архива key-handler.zip, прикрепленного к этой статье, в /usr/lib/plesk-9.0/ (в 32-разрядных системах) и в /usr/lib64/plesk-9.0/ (в 64-разрядных системах).

Attachments

dd0611b6086474193d9bf78e2b293040 a914db3fdc7a53ddcfd1b2db8f5a1b9c 29d1e90fd304f01e6420fbe60f66f838 56797cefb1efc9130f7c48a7d1db0f0c e8756e9388aeca36710ac39e739b2b37 1e5db16426987d561060acdf56d947b4 6311ae17c1ee52b36e68aaf4ad066387 147b9e14b9c9ab8c2e7cd2a7443fe1f8 33c4522b6fa9ca8e050f19b889fb58f1 01bc4c8cf5b7f01f815a7ada004154a2 0a53c5a9ca65a74d37ef5c5eaeb55d7f 1e0c43ccf6ca78fa6744efc9edbc0659 742559b1631652fadd74764ae8be475e e335d9adf7edffca6a8af8039031a4c7 2a5151f57629129e26ff206d171fbb5f aea4cd7bfd353ad7a1341a257ad4724a

Email subscription for changes to this article
Save as PDF