Article ID: 111609, created on Jan 27, 2012, last review on May 8, 2014

  • Applies to:
  • Virtuozzo containers for Linux 4.6
  • Virtual Automation 4.6

Эта статья рассказывает, как зарегистрировать сервер PVCfL 4.7 в PBA-S 4.0 и ранее с помощью режима совместимости.

ПРИМЕЧАНИЕ. Если вы пользуетесь PBA-S 4.1 и выше, не используйте режим совместимости для регистрации серверов.

Инструкции по регистрации Parallels Virtuozzo Containers для Linux 4.6 смотрите в этой статье:

111609: Как зарегистрировать сервер Parallels Virtuozzo Containers для Linux 4.6 в PBA-S с помощью режима compat

ПРИМЕЧАНИЕ. WACP работает только в режиме совместимости. Предоставленные здесь библиотеки предназначены для PVA Agent 6.0.

Для серверов x86_64:

Чтобы зарегистрировать Parallels Virtuozzo Containers для 64-разрядной Linux 4.7 в PBA-S:

  1. Убедитесь, что у вас установлен PVA Agent с компонентом Parallels Power Panel:

    # rpm -qa 'pva-pp*'
    

    Если он отсутствует в списке, вам нужно установить его с помощью команды pva-setup.

  2. Убедитесь, что у вас уже установлен PVA Agent версии 6.0. Номер сборки должен быть не ниже 6.0-2152:

    # rpm -qa 'pva-release*'
    

    Если версия PVA более ранняя, вам нужно сначала обновить ее до 6.0.

  3. Создайте пользователя vzagent0 с правами администратора и папку для него:

    # adduser -u 0 -o -g 0 -G 1,2,3,4,6,10 -M vzagent0
    # mkdir /home/vzagent0
    
  4. Измените стандартную оболочку и пароль для этого пользователя:

    # chsh -s /opt/pva/agent/bin/vzlcon vzagent0
    # passwd vzagent0
    
  5. Скачайте и распакуйте модуль совместимости для PVA:

    # wget http://download.pa.parallels.com/pva/6.0/hotfixes/compat/VZAOpCompat_x64.zip
    # unzip VZAOpCompat_x64.zip -d /opt/pva/agent/plugins/
    
  6. Установите инструмент compat:

    # yum install perl-CGI
    # rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/analog-5.32-1.5.swsoft.x86_64.rpm
    # rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-lib-4.0.0-79.swsoft.x86_64.rpm
    # rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-opcontrol-4.0.0-79.swsoft.x86_64.rpm
    # rm -rf /vz/root/1/var/vzagent/tmp
    # mkdir -p /vz/root/1/var/vzagent
    # ln -s /var/opt/pva/agent/tmp /vz/root/1/var/vzagent/tmp
    # vzagent_compat_ctl start
    
  7. Перезапустите PVA:

    # pvaagent restart
    
  8. Добавьте инструмент compat в автозагрузку:

    # ln -s /usr/sbin/vzagent_compat_ctl /etc/init.d/vzagent_compat_ctl
    # chkconfig --add vzagent_compat_ctl
    # chkconfig vzagent_compat_ctl on
    
  9. Добавьте поддержку протокола SSH1, изменив значение параметра /etc/ssh/sshd_config на Protocol 2,1:

    # vim /etc/ssh/sshd_config
    # service sshd restart
    
  10. Зарегистрируйте физический сервер в PBA-S:

    • Перейдите в PBA-S PCC -> Директор служб -> Менеджер Virtuozzo -> Серверы -> Новый сервер (или выберите существующий).
    • Введите IP-адрес физического сервера в поле IP-адрес.
    • Введите "vzagent0" в поле Логин.
    • Введите пароль из пункта 4

Для серверов i386:

Чтобы зарегистрировать Parallels Virtuozzo Containers для 32-разрядной Linux 4.7 в PBA-S:

  1. Убедитесь, что у вас установлен PVA Agent с компонентом Parallels Power Panel. Номер сборки должен быть не ниже 6.0-2152:

    # rpm -qa 'pva-pp*'
    

    Если он отсутствует в списке, вам нужно установить его с помощью команды pva-setup.

  2. Убедитесь, что у вас уже установлен PVA Agent версии не ниже 6.0-2152:

    # rpm -qa 'pva-release*'
    

    Если версия PVA более ранняя, вам нужно сначала обновить ее до 6.0.

  3. Создайте пользователя vzagent0 с правами администратора и папку для него:

    # adduser -u 0 -o -g 0 -G 1,2,3,4,6,10 -M vzagent0
    # mkdir /home/vzagent0
    
  4. Измените стандартную оболочку и пароль для этого пользователя:

    # chsh -s /opt/pva/agent/bin/vzlcon vzagent0
    # passwd vzagent0
    
  5. Скачайте и распакуйте модуль compat для PVA:

    # wget http://download.pa.parallels.com/pva/6.0/hotfixes/compat/VZAOpCompat_i386.zip
    # unzip VZAOpCompat_i386.zip -d /opt/pva/agent/plugins/
    
  6. Установите инструмент compat:

    # yum install perl-CGI
    # rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/analog-5.32-1.5.swsoft.i386_.rpm
    # rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-lib-4.0.0-79.swsoft.i386_.rpm
    # rpm -i --force http://download.pa.parallels.com/pva/6.0/hotfixes/compat/vzagent-compat-opcontrol-4.0.0-79.swsoft.i386_.rpm
    # rm -rf /vz/root/1/var/vzagent/tmp
    # mkdir -p /vz/root/1/var/vzagent
    # ln -s /var/opt/pva/agent/tmp /vz/root/1/var/vzagent/tmp
    # vzagent_compat_ctl start
    
  7. Перезапустите PVA:

    # pvaagent restart
    
  8. Добавьте инструмент compat в автозагрузку:

    # ln -s /usr/sbin/vzagent_compat_ctl /etc/init.d/vzagent_compat_ctl
    # chkconfig --add vzagent_compat_ctl
    # chkconfig vzagent_compat_ctl on
    
  9. Добавьте поддержку протокола SSH1, изменив значение параметра /etc/ssh/sshd_config на Protocol 2,1:

    # vim /etc/ssh/sshd_config
    # service sshd restart
    
  10. Зарегистрируйте физический сервер в PBA-S:

    • Перейдите в PBA-S PCC -> Директор служб -> Менеджер Virtuozzo -> Серверы -> Новый сервер (или выберите существующий).
    • Введите IP-адрес физического сервера в поле IP-адрес.
    • Введите "vzagent0" в поле Логин.
    • Введите пароль из пункта 4

400e18f6ede9f8be5575a475d2d6b0a6 d02f9caf3e11b191a38179103495106f 319940068c5fa20655215d590b7be29b e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 caea8340e2d186a540518d08602aa065 36627b12981f68a16405a79233409a5e d16a8794b3bdb3f66571d469e71906a9

Email subscription for changes to this article
Save as PDF