Article ID: 114245, created on Nov 21, 2012, last review on Mar 4, 2015

  • Applies to:
  • Plesk 12.5 for Linux
  • Plesk 12.0 for Linux
  • Plesk 11.0 for Linux
  • Plesk 11.5 for Linux

Симптомы

Эта проблема может иметь три симптома:

Симптом 1

Вы добавили новый сетевой интерфейс с помощью следующей команды:

ip addr add 10.9.23.81 peer 10.9.23.65/32 brd 10.9.23.95 dev venet0:0

и обновили IP-адрес в веб-интерфейсе Plesk: Инструменты и настройки > Обновить.

Plesk распознает GW IP 10.9.23.65 как основной IP-адрес интерфейса.

IP-адрес 10.9.23.65 будет добавлен вместо 10.9.23.81.

Симптом 2

Вы хотите использовать nginx, но при его запуске возникает ошибка:

[emerg] bind() to 10.9.23.65:80 failed (99: Cannot assign requested address) ;

Симптом 3

На домашней странице Plesk показывается следующая ошибка:

Из-за ошибок в шаблонах конфигурации не удалось создать новые конфигурационные файлы для веб-сервера Apache: nginx: [emerg] bind() to 10.9.23.65:80 failed (99: Cannot assign requested address)
nginx: configuration file /etc/nginx/nginx.conf test failed . Сообщение с подробными описаниями ошибок было отправлено на ваш адрес электронной почты. Пожалуйста, устраните эти ошибки и нажмите здесь, чтобы заново создать поврежденные конфигурационные файлы, или здесь, чтобы создать все конфигурационные файлы.

Причина

Эта проблема возникает из-за того, что после смены IP-адреса не выполняется автоматическое обновление конфигурационных файлов nginx.

Решение

Чтобы устранить эту проблему, используйте следующие команды:

# /usr/local/psa/bin/reconfigurator --autoconfigure
# /usr/local/psa/admin/sbin/httpdmng --reconfigure-all
# /etc/init.d/nginx restart

Пожалуйста, обратите внимание на вывод первой команды. Он может содержать один и тот же IP-адрес в нескольких разделах, а некоторые IP-адреса из списка 'Database' могут отсутствовать в списке 'Actual':

[root@srv ~]# /usr/local/psa/bin/reconfigurator --autoconfigure
Database: [<1.2.3.4>, <5.6.7.8>, <9.1.2.2>, <8.1.2.3>, <7.1.2.3>, <6.1.2.3>, <0000:a0a0:0000:a0:225:00a0:0a00:0a00]
Actual: <1.2.3.4>, <5.6.7.8>, <9.1.2.2>, <8.1.2.3>, <7.1.2.3>, <6.1.2.3>]
Removed IPs: [] [<0000:a0a0:0000:a0:225:00a0:0a00:0a00>]
Added IPs: [] []
Mapping: {}
Old not remapped: [<0000:a0a0:0000:a0:225:00a0:0a00:0a00>]
New not used: []

Это означает, что Ipv6-адрес 0000:a0a0:0000:a0:225:00a0:0a00:0a00 поврежден.

Его можно восстановить следующим образом:

  1. Откройте Инструменты и настройки > IP-адреса.
  2. Если в списке есть IP-адрес, помеченный восклицательным знаком и статусом поврежден, нажмите восстановить.
  3. Если поврежденных IP-адресов нет, нажмите перечитать. Восстановите обнаруженные поврежденные IP, как описано выше.

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c aea4cd7bfd353ad7a1341a257ad4724a 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 01bc4c8cf5b7f01f815a7ada004154a2 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 742559b1631652fadd74764ae8be475e

Email subscription for changes to this article
Save as PDF