Article ID: 114378, created on Jul 26, 2012, last review on Sep 16, 2014

  • Applies to:
  • Plesk 10.4 for Linux/Unix
  • Plesk 10.3 for Linux/Unix
  • Plesk 10.2 for Linux/Unix
  • Plesk 10.1 for Linux/Unix
  • Virtuozzo containers for Linux 4.7

Примечания к выпуску

Эта статья рассказывает, как устранить наиболее критичные уязвимости в Plesk 8.x, 9.0.x - 9.5.5 и 10.0.x - 10.4.4 для Linux. Если у вас более ранняя версия (7.x, 6.x и т.д.), вам все равно необходимо обновить ее до одной из последних версий, не подверженных уязвимости.

Примечание. Нужные вам исправления входят в следующие микрообновления:

8.6.0 MU#15

9.5.4 MU#21

10.0.1 MU#14

10.1.1 MU#23

10.2.0 MU#17

10.3.1 MU#18

10.4.4 MU#39

Решение

  1. Создайте временную папку:

    # mkdir plesk_remote_vulnerability_fix_deployer
    
  2. Перейдите в созданную папку:

    # cd plesk_remote_vulnerability_fix_deployer
    
  3. Скачайте прикрепленный файл (md5sum: 7589fba44bd3d5b8c5b5c430a86d79f7) и распакуйте его:

    # wget http://kb.sp.parallels.com/Attachments/kcs-23896/plesk_remote_vulnerability_fix_deployer.tar.gz
    # tar -xzf plesk_remote_vulnerability_fix_deployer.tar.gz
    
  4. Находясь в созданной временной папке, выполните следующую команду:

    # /usr/local/psa/admin/bin/php plesk_remote_vulnerability_fix_deployer.php
    

Примечание. Чтобы упростить групповую установку в Linux-окружении Parallels Virtuozzo Containers (PVC), рекомендуем использовать сценарий plesk_remote_vulnerability_fix_mass_deployer:

  1. Сохраните этот архив в отдельную папку на физическом сервере: plesk_remote_vulnerability_fix_mass_deployer.tar.gz (md5sum: 2dd4f90ca8f591814dd7d7d2cf2e8477)

  2. Распакуйте архив:

    # tar -xzf plesk_remote_vulnerability_fix_mass_deployer.tar.gz
    
  3. Запустите содержащийся в нем сценарий от лица администратора:

    # ./plesk_remote_vulnerability_fix_mass_deployer.sh 
    

Примечание для пользователей Expand

Если у вас 9.5.4 для Linux или 9.5.4/9.5.5 для Windows под управлением Parallels Expand, то после применения микрообновлений или индивидуальных исправлений вам необходимо установить исправление для совместимости Parallels Plesk Panel 9.5.4 и Parallels Plesk Expand 2.3.2+.

Attachments

56797cefb1efc9130f7c48a7d1db0f0c a914db3fdc7a53ddcfd1b2db8f5a1b9c e8e50b42231236b82df27684e7ec0beb 2897d76d56d2010f4e3a28f864d69223 d02f9caf3e11b191a38179103495106f 29d1e90fd304f01e6420fbe60f66f838 e8756e9388aeca36710ac39e739b2b37 dd0611b6086474193d9bf78e2b293040 0c05f0c76fec3dd785e9feafce1099a9 f4ce8084cb23619ef5fe9428ecc388ea def31538ba607bde27398f48ab5956be d3c493291d6d9f66837ac7495dfea9ca

Email subscription for changes to this article
Save as PDF