Article ID: 117558, created on Dec 13, 2013, last review on Sep 22, 2014

  • Applies to:
  • Odin Business Automation Standard 4.5
  • Odin Business Automation Standard 4.3
  • Plesk 12.0 for Linux
  • Plesk 11.5 for Linux
  • Virtuozzo 6.0
  • Virtuozzo containers for Linux 4.7
  • Virtuozzo containers for Linux 4.6

Симптомы

При установке шаблона postfix возникает следующая ошибка:

Error: plesk-mail-mc-driver conflicts with postfix
Error: plesk-mail-pc-driver conflicts with sw-msmtp

Вы уже обновили EZ-шаблоны на физическом сервере, как описано в этой статье.

Причина

Шаблон pp11.5-msmtp установлен в контейнере:

# vzpkg list CTID
centos-6-x86_64                      2013-09-17 19:25:18
centos-6-x86_64      pp              2013-09-18 08:18:32
centos-6-x86_64      pp11.5-msmtp    2013-09-18 08:18:32

Он не может быть заменен на pp-postfix из-за ошибки зависимости.

Решение

Эта проблема будет устранена в одном из обновлений для Parallels Plesk Panel 11.5.30. Идентификатор проблемы - PPP-3792.

Решение 1

Добавьте следующие строки в конфигурационный файл шаблона ОС на физическом сервере. Пример для шаблона ОС centos-6-x86_64:

/vz/template/centos/6/x86_64/config/app/pp-postfix/default/pre-install

Решение для конфликта plesk-mail-mc-driver + postfix:

rpm -e pp11.5-msmtp --nodeps
rpm -e plesk-mail-mc-driver --nodeps
rpm -e plesk-mail-pc-driver --nodeps

Решение 2

Для пользователей PBA-S: Установите пакет в Plesk с помощью автоустановщика и затем зарегистрируйте его в PBA-S.

  1. Установите приложение postfix с помощью автоустановщика Plesk:

    [root@container ~]# /usr/local/psa/admin/sbin/autoinstaller --select-release-id PLESK_11_5_30 --install-component postfix
    
  2. Установите шаблон на контейнер с физического сервера:

    [root@node ~]# vzpkg install CTID pp-postfix
    ...
    Setting up Install Process
    Package plesk-mail-pc-driver-11.5.30-cos6.build115130801.11.x86_64 already installed and latest version
    Package psa-mail-driver-common-11.5.30-cos6.build115130801.11.x86_64 already installed and latest version
    Package psa-courier-imap-4.12.0-cos6.build115130710.20.x86_64 already installed and latest version
    Package 2:postfix-2.8.14-13040119.x86_64 already installed and latest version
    Nothing to do
    ...
    [root@node ~]#
    
  3. Исправьте статус приложения в PBA-S:

    Директор служб > Менеджер Virtuozzo > Контейнеры > номер контейнера > Приложения > Pp postfix > Отметить как установленное
    

Также смотрите:

Не удается обновить шаблоны pp в контейнере: plesk-mail-mc-driver conflicts with postfix

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 01bc4c8cf5b7f01f815a7ada004154a2 29d1e90fd304f01e6420fbe60f66f838 0a53c5a9ca65a74d37ef5c5eaeb55d7f 400e18f6ede9f8be5575a475d2d6b0a6 caea8340e2d186a540518d08602aa065 807e9c1dc97aefd951b912a17e50c428 70a5401e8b9354cd1d64d0346f2c4a3e c62e8726973f80975db0531f1ed5c6a2 2897d76d56d2010f4e3a28f864d69223 0dd5b9380c7d4884d77587f3eb0fa8ef e8e50b42231236b82df27684e7ec0beb d02f9caf3e11b191a38179103495106f 624ca542e40215e6f1d39170d8e7ec75 2a5151f57629129e26ff206d171fbb5f e335d9adf7edffca6a8af8039031a4c7 0c05f0c76fec3dd785e9feafce1099a9 36627b12981f68a16405a79233409a5e

Email subscription for changes to this article
Save as PDF