Article ID: 797, created on Jun 13, 2010, last review on Mar 31, 2016

  • Applies to:
  • Plesk Automation 11.5
  • Plesk

Симптомы

При отправке писем на тот или иной домен в ответ приходит уведомление о том, что такой почтовый ящик не существует.

Текст уведомления может быть следующий:

Hi. This is the qmail-send program at SERVER. I'm afraid I wasn't able to deliver your message to the following addresses. This is a permanent error; I've given up. Sorry it didn't work out

This address no longer accepts mail.

Sorry, no mailbox here by that name. (#5.1.1)

550 Requested action not taken: mailbox unavailable Givingup.

User not known Giving up.

Sorry your message to mailname@domain.tld cannot be delivered. This account has been disabled or discontinued.

Причина

Такие сообщения об ошибках генерируются разными SMTP-серверами, когда вы отправляете письма на несуществующий почтовый ящик.

Решение

Проверьте MX-запись домена, на который вы отправляете письма:

В Windows

c:\Nmap>nslookup -q=mx domain.tld
Non-authoritative answer:
domain.com     MX preference = 10, mail exchanger = mail.domain.tld
mail.domain.com  internet address = 1.2.3.4

В Linux

# dig mx +short domain.tld 
mail.domain.tld
# dig +short mail.domain.tld
1.2.3.4
  1. Если MX-записи указывают на другой сервер и такого домена нет на сервере Parallels Plesk Panel (Plesk), вам нужно узнать у администратора сервера, существует ли такой почтовый ящик.

  2. Если ошибка возникает, когда вы отправляете почту на собственный сервер Plesk, убедитесь, что такой адресат действительно существует и для данного домена включена служба Почта.

    Также проверьте, что запись MX (A) для домена, на который вы отправляете почту, указывает на соответствующий сервер.

  3. Если MX-запись указывает на другой сервер, но домен размещен на сервере Plesk, исправьте MX-записи в настройках DNS этого домена. Отключите почту на странице Plesk > Домены > domain.com > Панель управления > Почта > Настройки.

  4. Если на сервере установлен DrWeb без действительной лицензии, убедитесь, что параметр LicenseLimit имеет значение "pass" в /etc/drweb/drweb_qmail.conf:

    # grep License /etc/drweb/drweb_qmail.conf
    LicenseLimit = pass
    
  5. Убедитесь, что домен, на который вы отправляете почту, не значится в файле "/var/qmail/control/locals". В этом файле должна быть запись "localhost".

  6. Также эта проблема может возникать из-за того, что на сервере запущена другая служба SMTP. Это можно проверить по приветствию на порту SMTP. Вы должны увидеть следующее:

    # telnet 1.2.3.4 25
    Trying 1.2.3.4...
    Connected to domain.tld (1.2.3.4).
    Escape character is '^]'.
    220 domain.tld ESMTP
    

    Здесь 1.2.3.4 - это IP-адрес вашего сервера Plesk, а "domain.tld" - имя сервера (Qmail берет его из /var/qmail/control/me). Если вы видите другое приветствие, смотрите статью 1374.

  7. Вы также можете использовать следующую утилиту:

    # /usr/local/psa/admin/sbin/mchk
    

    Эта утилита пересоздает конфигурационные файлы qmail, восстанавливает недостающие папки почтовых аккаунтов и т.д. - согласно базе данных Plesk. Обратите внимание, что работа этой утилиты может занять длительное время, в течение которого почтовые аккаунты будут недоступны.

a914db3fdc7a53ddcfd1b2db8f5a1b9c 56797cefb1efc9130f7c48a7d1db0f0c 33a70544d00d562bbc5b17762c4ed2b3 caea8340e2d186a540518d08602aa065 e0aff7830fa22f92062ee4db78133079

Email subscription for changes to this article
Save as PDF