Article ID: 8659, created on Jul 15, 2010, last review on May 5, 2014

  • Applies to:
  • Plesk for Windows

Описание проблемы

Если при публикации сайта появляется сообщение об ошибке “Указанный для публикации сервер не поддерживает ionCube Loader", значит,  на PHP5 клиента установлен Zend Optimizer.

Решение

Для решения этой проблемы в php.ini необходимо перечислить расширения в правильной последовательности:

%plesk_dir%\Additional\PleskPHP5\php.ini

[ioncube]
zend_extension_ts="%plesk_dir%\Additional\PleskPHP5\ext\ioncube_loader_win_5.2.dll"
zend_extension_ts="%plesk_dir%\Additional\PleskPHP5\ext\Zend\lib\ZendExtensionManager.dll"


Примечание! Значение %plesk_dir% необходимо заменить на реальный путь (см. "Дополнительную информацию"). Например:

zend_extension_ts="C:\Program files\Parallels\Plesk\Additional\PleskPHP5\ext\ioncube_loader_win_5.2.dll"
zend_extension_ts="C:\Program files\Parallels\Plesk\Additional\PleskPHP5\ext\Zend\lib\ZendExtensionManager.dll"

Дополнительная информация

%plesk_dir% - это переменная, указывающая на папку, в которой установлена Parallels Small Business Panel. Обычно это C:\Program files\Parallels\Plesk

a914db3fdc7a53ddcfd1b2db8f5a1b9c 85a92ca67f2200d36506862eaa6ed6b8 56797cefb1efc9130f7c48a7d1db0f0c

Email subscription for changes to this article
Save as PDF